Has anyone found a good fix for when your Ledger device stops showing the approval request on the dongle?

I did search. Google. Here.

So I use MetaMask. My Ledger is connected to MetaMask.

As you know, when you go to, say, do a swap, MetaMask pops up, has the little blue box asking you to connect your device, put in your code, open the Ethereum app.

Ok, so I do that and then confirm and then wait… And nothing pops up on my device. And so now these transactions are sitting stuck as well…… Lol

I did already do the advanced options MetaMask so it would connect to Ledger Live. Had Ledger Live open and dongle connected and open and still just sat there when I confirmed in metamask.

Thanks so much for any help. I'm sorry if this is asked a lot. I tried searching. Wasn't sure how to word it without using too many words.

Has anyone found a good fix for when your Ledger device stops showing the approval request on the dongle?

5 thoughts on “Has anyone found a good fix for when your Ledger device stops showing the approval request on the dongle?”

  1. The Ledger subreddit is continuously targeted by scammers. Ledger Support will never send you private messages. Never share your 24-word recovery phrase with anyone, never enter it on any website or software, even if it looks like it’s from Ledger. Only keep the recovery phrase as a physical paper or metal backup, never create a digital copy in text or photo form. Learn more at https://reddit.com/r/ledgerwallet/comments/ck6o44/be_careful_phishing_attacks_in_progress/

    I am a bot, and this action was performed automatically. Please contact the moderators of this subreddit if you have any questions or concerns.

  2. > Had Ledger Love Live open

    Ledger Live should be closed, not open.

    Do you have blind signing enabled in the Ethereum app ?

  3. It was a little random for me but now since the last firmware and metamask update I cannot remember when was the last time I had a problem.
    So here is my setup for metamask:

    • On windows
    • Up to date Nano X and nano S
    • Up to date firefox and Brave (chromium)
    • Metamask set up to use webHID (to comunicate with ledger)
    • I unlock and go to the ethereum app before unlocking metamask

    I don’t know how useful it is to you but it works perfectly for me

  4. When this happens to me, here is what I do to fix the communication between MM and my ledger:

    1 – quit the Ethereum app on the ledger

    2 – In the browser extension dashboard, disable, then re-enable the MM extension

    3 – restart the Ethereum app on the ledger

    4 – Reload the browser page that interacts with MM

    You will need to login again into your MM

    On Chrome, this usually fixes the communication issues between MM and my ledger.

Leave a Comment