Cannot find my address

EDIT: For those that come across this later. This resulted because the wallet was not created with the current Trezor. Metamask used my cached Trezor when it created the wallet. Funds are moved and safe now. Thank you.

Hi,

I created a wallet yesterday with Trezor and Metamask. I'm no longer able to see that wallet in my metamask. Please help. Here is my basic post-mortem trying to identify where I went wrong:

  1. I initialized on Trezor Suite generally following the same steps as https://trezor.io/learn/a/get-started-with-the-trezor-safe-3. I chose 24 words instead of 12. I set a PIN.
  2. I’m quite certain I used a hidden wallet. The passphrase was entered on the Trezor and the menu was lowercase characters so I’m quite sure the passphrase is lowercase characters only.
  3. I backed up my 24 words to Trezor Keep
  4. I verified the 24 words twice via Trezor Suite “Check backup”. Once by me and once by my wife. All words were entered via the Trezor.
  5. I opened metamask and created an account. Exported “public key of Ethereum account”, used a hidden wallet (I believe), confirmed on Trezor
  6. I selected the 4th wallet (see image 1)
  7. I transferred all of my funds to my new address
  8. I tried to sign a message on a web3 platform (Plutus) to prove ownership of my address. It was unsuccessful with a Chrome dev tools error console saying something to the effect that the address of the sign didn’t match. Maybe it didn’t match the metamask/trezor address?
  9. I tried to create a new wallet on metamask to select address 1 instead of address 4 to ensure I could see it in Trezor Suite and hopefully it would fix the issue. However, I couldn’t add a new wallet from the same Trezor as the same 5 addresses kept appearing.
  10. The address was labeled as Trezor in Metamask so it was absolutely from Trezor somehow
  11. I removed the account from metamask via “Forget this device”
  12. I tried to add the Trezor to metamask via hidden wallet (2 different passphrases [both uppercase and lowercase – just to be sure] and I also tried my PIN in the passphrase) and no hidden wallet and no option provides the same set of addresses as above which have all of my funds
  13. The address still has the funds so I wasn’t hacked
  14. I’ve tried restarting and using a different computer with the same results (see image 2)

What have I done wrong? How can I access it?

I tried using https://findeth.io/flow/address, but “This application was using Trezor Connect v7, which has been discontinued.” Are there other tools?

I've tried derivation paths m/44'/60'/0-4'/0-4 and none of them are the same addresses.

Please no DMs

I previously edited the above picture for reddit to remove the value of the assets and the last digits of each address

https://preview.redd.it/lixbyrvlhu9d1.png?width=509&format=png&auto=webp&s=f9226a0856c0a053158b1eeb494da232e0dadec4

EDIT: For those that come across this later. This resulted because the wallet was not created with the current Trezor. Metamask used my cached Trezor when it created the wallet. Funds are moved and safe now. Thank you.

5 thoughts on “Cannot find my address”

  1. Please bear in mind that no one from the Trezor team would send you a private message first.
    If you want to discuss a sensitive issue, we suggest contacting our Support team via the Troubleshooter: https://trezor.io/support/

    No one from the Trezor team (Reddit mods, Support agents, etc) would ever ask for your recovery seed!
    Beware of scams and phishings: https://blog.trezor.io/recognize-and-avoid-phishing-ef0948698aec

    I am a bot, and this action was performed automatically. Please contact the moderators of this subreddit if you have any questions or concerns.

  2. when you first use metamask (after install) it makes you create a hot wallet. before you can connect and use your trezor with metamask. Did you create the hot wallet and send the funds there by any chance?

    if not the above, my first guess at this is: you have the wrong passphrase. does account 1 address match the address in trezor suite? when using the passphrase you originally setup.

  3. From everything you’ve said, it’s 100% a passphrase issue. You need to verify that you’re indeed inputting the right phrase.

    You may need to brute-force the passphrase.

    Also, whatever you do, do not reset the Trezor. I hope you haven’t done so.

  4. This resulted because the wallet was not created with the current Trezor. Metamask used my cached Trezor when it created the wallet. Funds are moved and safe now. Thank you.

Comments are closed.